Cumberland County Remote Services

 

Please ignore any certificate warnings -- The certificate warnings will occur because we have not purchased a 3rd party internet approved certificate.

Internet Explorer is the only supported Web Browser

E-Mail Web Access

Remote Terminal Services

Remote Terminal Services Requires Windows XP SP3 and above with the latest RDP client.

To download the latest client, please click here and scroll down to the bottom of the page.

 

 

If you have any questions or problems, please submit a help request to our HelpDesk

 

TeamViewer for Remote Support TeamViewer for your
Remote Support!

WebClock